內容

IntelliJ 和 Android Studio

Dart 外掛程式 為 JetBrains 所開發的 IntelliJ Platform-based IDE 加入 Dart 支援。這些 IDE 提供特定開發技術獨有的功能。建議用於 Dart 和 Flutter 開發的 IDE 包括

無論您選擇哪一款 JetBrains IDE 來進行 Dart 開發,本頁面都提供資源,協助您快速上手,並在需要時找到更多資訊。

入門

#

如果您尚未擁有 IDE 和 Dart SDK,請取得它們。然後安裝 Dart 外掛程式,並告訴它 Dart SDK 的位置。

下載 IDE

#

如果您尚未擁有 JetBrains IDE,請安裝一款。選擇下列其中一款

下載 Dart SDK

#

如果您尚未擁有 Dart SDK,請安裝它。您可以單獨取得它,或下載包含完整 Dart SDK 的 Flutter SDK。

選擇下列其中一款

設定 Dart 支援

#

以下是設定 Dart 支援的方法之一

  1. 啟動 IDE,並安裝 Dart 外掛程式。

    1. 從歡迎畫面中,選擇 外掛程式
    2. 搜尋 Dart
    3. 安裝 Dart 外掛程式後,重新啟動 IDE。

  2. 建立新的 Dart 專案

    1. 從歡迎畫面中,按一下 新專案
    2. 在下一則對話方塊中,按一下 Dart

  3. 如果您未看到 Dart SDK 路徑的值,請輸入或選取它。

    例如,SDK 路徑可能是 <dart 安裝目錄>/dart/dart-sdk

  4. 選擇一個起始範本。

    1. 若要啟用起始範本,請按一下產生範例內容
    2. 挑選您想要的範本。
  5. 按一下下一步並繼續專案設定。

步驟 2 的替代方法是開啟現有的 Dart 專案,然後開啟其 pubspec.yaml 檔案或任何 Dart 檔案。

回報問題

#

請透過官方 JetBrains Dart 問題追蹤器 回報問題和意見回饋。

請包含預期行為、實際行為和螢幕截圖(如果合適)的詳細資料。

更多資訊

#

請參閱 JetBrains 網站以取得更多資訊。